Return to Cocos2d Playback Library

GAF Converter 5.5 Compatibility

Questions related to Cocos2d playback library should be asked here.

GAF Converter 5.5 Compatibility

Postby Sam Yelles » January 23rd, 2016, 2:59 am

hi

I just downloaded the free version of the GAF Converter 5.5 and converted a swf.But when I try to import the .gaf file and display it in my cocos2d project, i get this message on the console:

"Error: Tag [] hasn't been correctly read, tag length is not respected. Expected [-587241850] but actually [32]"

Any help please ?
I really need to validate the performance of your product before using it in our applications

Github issue : https://github.com/CatalystApps/Cocos2d ... r/issues/7
User avatar
Sam Yelles
 
Posts: 5
Joined: January 22nd, 2016, 8:18 am

Re: GAF Converter 5.5 Compatibility

Postby Dmitry Bushtets » January 23rd, 2016, 6:36 am

Hi!
Unfortunately I haven't any Mac near me now. I'll check this issue at Monday.
Sorry:(
User avatar
Dmitry Bushtets
 
Posts: 83
Joined: August 11th, 2014, 1:31 am

Re: GAF Converter 5.5 Compatibility

Postby Dmitry Bushtets » January 23rd, 2016, 6:49 am

Please note that cocos2d is no longer under development. We are focused at cocos2d-x
User avatar
Dmitry Bushtets
 
Posts: 83
Joined: August 11th, 2014, 1:31 am

Re: GAF Converter 5.5 Compatibility

Postby Sam Yelles » January 23rd, 2016, 4:28 pm

Dmitry Bushtets wrote:Hi!
Unfortunately I haven't any Mac near me now. I'll check this issue at Monday.
Sorry:(


ok, i hope that it's not a big issue. I would love to use it for our last project in cocos2D, it will save one of our games (even if we planned to use Unity for the next projects.)

I tried to install a previous version of GAF Converter, but it's seems that the certificate is no longer valid :/

have a good week
User avatar
Sam Yelles
 
Posts: 5
Joined: January 22nd, 2016, 8:18 am

Re: GAF Converter 5.5 Compatibility

Postby Dmitry Bushtets » January 25th, 2016, 2:30 am

I tried to install a previous version of GAF Converter, but it's seems that the certificate is no longer valid :/

You can devete GAF5.5 and install older version
User avatar
Dmitry Bushtets
 
Posts: 83
Joined: August 11th, 2014, 1:31 am

Re: GAF Converter 5.5 Compatibility

Postby Sam Yelles » January 25th, 2016, 3:39 am

Dmitry Bushtets wrote:You can devete GAF5.5 and install older version


I tried to use GAF Converter 5.5 and 5.2, the same Tag Error issue.

I tried to install GAF Converter 3.15, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, 5.0, 5.1 : unable to install due to invalid certificate.
User avatar
Sam Yelles
 
Posts: 5
Joined: January 22nd, 2016, 8:18 am

Re: GAF Converter 5.5 Compatibility

Postby vadym.mitin » January 25th, 2016, 4:01 am

Sam,

Before trying to install older version of the GAF Converter you need to uninstall current version of the GAF Converter. They are using different certificates.
User avatar
vadym.mitin
 
Posts: 254
Joined: December 4th, 2013, 8:00 am

Re: GAF Converter 5.5 Compatibility

Postby Sam Yelles » January 25th, 2016, 7:49 am

Vadym Mitin GAF wrote:Before trying to install older version of the GAF Converter you need to uninstall current version of the GAF Converter. They are using different certificates.


Ok i see... thanks...

I tried GAF Converter 3.15, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, 5.0, 5.1, 5.2 & 5.5.

Only the 3.15 works with Cocos2dGAFPlayer, but it display the entire Atlas Image... is there a way to have the 5.5 working or at least have a correct display ? a header issue may be ?
User avatar
Sam Yelles
 
Posts: 5
Joined: January 22nd, 2016, 8:18 am

Re: GAF Converter 5.5 Compatibility

Postby Sam Yelles » May 23rd, 2016, 2:25 am

No solution ? :cry:
User avatar
Sam Yelles
 
Posts: 5
Joined: January 22nd, 2016, 8:18 am

Re: GAF Converter 5.5 Compatibility

Postby Dmitry Bushtets » May 23rd, 2016, 4:25 am

Hello!
Unfortunately the only solution is to use cocos2dx engine ;(
User avatar
Dmitry Bushtets
 
Posts: 83
Joined: August 11th, 2014, 1:31 am

Return to Cocos2d Playback Library

Who is online

Users browsing this forum: No registered users and 1 guest